На главнуюПользователиНовые сообщенияОбратная связь
DGR.Su - Компьютерный форум IT, сети и мобильные устройства Мастерская

Программирование в среде 1С: Предприятие

Страница 2 из 7 1  2  3  4  5  6 / Последняя »
Boss Artem 30.08.2006, 17:49
Появилось еще несколько вопросов по 1С:ТиС:
- как сделать, чтобы в документе быстрая продажа по умолчанию стоял некоторый конкретный контрагент (ну и договор соответственно.)
- как правильно забивать товар - через ввод остатков или оприходованием?
- возможно ли сделать отчет в котором будет информация - какой пользователь какого числа какой товар и на какую сумму продал?
- как можно автоматизировать забивание в базу приходных накладных с товаром, купленным на оптовке, как обычно поступают в этом случае? Если товара немного, то можно и руками конечно забить, а если много? Наверняка можно как-то выгрузить эту накладную у поставщика и потом загрузить в 1С? Или я неправ?

И еще - может поделитесь каким-нить мануалом по работе в ТиС, в котором описывается оформление основных моментов в работе магазина и мелкая настройка конфы.
ап=)
Serge 30.08.2006, 18:47
1 - добавить в исходный код присвоение нужному реквизиту нужного значения контрагента.
2 - это скорее к бухгалтерам.
3, 4 - теоретически можно все что угодно запрограммировать. )))
----------------------------------------------------------
по первому пункту
Примерно так (как я понял у тебя 1с77):
- в режиме конфигуратора открыть программный код формы нужного документа
- найти там процедуру "ВводНового()" (или ВводНаОсновании, смотря что нужно, если нет, то можно самому создать)
- в процедуру добавить примерно такой код
(допустим у документа есть реквизит Контрагент)

Спр = СоздатьОбъект("Справочник.Контрагенты");
Если Спр.НайтиПоКоду("12345") = 1 Тогда
// (или 12345 - смотря какой тип кода у справочника - строка или число)
Контрагент = Спр.ТекущийЭлемент();
КонецЕсли;

Реквизит Договор на форме связать с реквизитом Контрагент
shiling 03.09.2006, 07:03
И еще - может поделитесь каким-нить мануалом по работе в ТиС, в котором описывается оформление основных моментов в работе магазина и мелкая настройка конфы.
Книжка_по_ТиС.rar .... D0%BE_%D0%A2%D0%B8%D0%A1.rar|3******3|A2******9A86797C ECB69744B88A5D4901|h=KUXJQLVYKYA5RQXV6NXBTXAJFGKLN 4GK|/) - 366.87 Kb [1******5]
shiling 03.09.2006, 07:15
по первому пункту
Примерно так (как я понял у тебя 1с77):
- в режиме конфигуратора открыть программный код формы нужного документа
- найти там процедуру "ВводНового()" (или ВводНаОсновании, смотря что нужно, если нет, то можно самому создать)
- в процедуру добавить примерно такой код
(допустим у документа есть реквизит Контрагент)

Иделогически неправильно в корне.
1С придерживается во всех конфах при вводе нового дока вызова процедуры глЗаполнитьШапку из глобального модуля. Весь функционал заполнения реквизитов там.
И кстате требуемое там есть :
Если глЕстьРеквизитШапки("Контрагент",ВидДок) = 1 Тогда
Если ПустоеЗначение(Конт.Контрагент) = 1 Тогда
// заполняем, если пустой
Если Нрег(ВидОперации) = "покупка" Тогда
Конт.Контрагент = глЗначениеПоУмолчанию("ОсновнойПоставщик");

ИначеЕсли Нрег(ВидОперации) = "продажа" Тогда
Конт.Контрагент = глЗначениеПоУмолчанию("ОсновнойПокупатель");
КонецЕсли;
КонецЕсли;

Если глЕстьРеквизитШапки("Договор",ВидДок) = 1 Тогда
// установим договор (есть контрагент, есть и договор)
Если ПустоеЗначение(Конт.Договор) = 1 Тогда
Конт.Договор = Конт.Контрагент.ОсновнойДоговор;

// заполним реквизиты по документу в соответствии с договором
глПриИзмененииДоговора(Конт);
КонецЕсли;
КонецЕсли;
КонецЕсли;
Поэтому порядок действий :

Справочники-Структура компании-Пользователи. Для каждого пользователя задаем Основной покупатель () или если надо Основной поставщик. Во всех документах автоматом будет подставляться.
НаДюШкА 08.09.2006, 12:50
как правильно забивать товар - через ввод остатков или оприходованием?

все зависит от того, что вы делаете, это покупка или при начале ведения программы у вас есть какие-то остатки на складе - тогда ввод остатков
НаДюШкА 08.09.2006, 12:51
пишите в Аську 3******8 быстрый ответ по всем вопросам
Boss Artem 08.09.2006, 15:54
как правильно забивать товар - через ввод остатков или оприходованием?

все зависит от того, что вы делаете, это покупка или при начале ведения программы у вас есть какие-то остатки на складе - тогда ввод остатков
Мдя... оказалось что вообще надо было поступлением ТМЦ забивать....
Dj_Dreamer 06.05.2007, 00:03
У нас стоит 7.7 ИТРП и 8.1.
Нужно справочник номенклатуры перенести из 7-ки в 8-ку, только названия (и, возможно, единицы измерения). 1с-ки клиент-серверные. Можно сделать всё запросом sql? Если да, то на что нужно обратить внимание чтобы не повредить структуру бд.
Или может другой есть способ, более простой? Пробовал всё сделать через конфигурацию "Конвертация данных 2.0", только она не ставится на 8.1 (наверное только на 8.0 можно поставить).
Serge 06.05.2007, 11:21
Если есть малейшие навыки программирования в 1с, то можно написать простенькие обработки для выгрузки-загрузки данных, да хоть через промежуточный текстовый файл.
shiling 09.05.2007, 02:20
У нас стоит 7.7 ИТРП и 8.1.
Нужно справочник номенклатуры перенести из 7-ки в 8-ку, только названия (и, возможно, единицы измерения). 1с-ки клиент-серверные. Можно сделать всё запросом sql? Если да, то на что нужно обратить внимание чтобы не повредить структуру бд.
Или может другой есть способ, более простой? Пробовал всё сделать через конфигурацию "Конвертация данных 2.0", только она не ставится на 8.1 (наверное только на 8.0 можно поставить). Механизмов для переноса много. OLE, XML, через текстовый файл... А также могу предложить свои услуги:D
Jura_22 05.11.2007, 19:43
Народ подскажите, есть такая проблемма, в воинской части стоит 1с(лицензия), с рашренной папки на сервере получают доступ к базе 2 бухглатера, но сейчас они расширяются и еще 2 бухгалтеров садят, все это дело скисает моментально, тоесть 3 еще работаю, но как только кто-либо начинает формировать отчет, все пипец, какие есть выходы, чтоб 1с работала быстрее?
Штурман 05.11.2007, 20:14
Народ подскажите, есть такая проблемма, в воинской части стоит 1с(лицензия), с рашренной папки на сервере получают доступ к базе 2 бухглатера, но сейчас они расширяются и еще 2 бухгалтеров садят, все это дело скисает моментально, тоесть 3 еще работаю, но как только кто-либо начинает формировать отчет, все пипец, какие есть выходы, чтоб 1с работала быстрее?

Если 1C работает в клиент-серверном варианте, то необходим анализ работы сервера. Используя системный монитор (для Windows-сервера) необходимо определить "бутылочное горло".
Dj_Dreamer 06.11.2007, 17:51
Если 1C работает в клиент-серверном варианте, то необходим анализ работы сервера. Используя системный монитор (для Windows-сервера) необходимо определить "бутылочное горло".
в клиент-серверном варианте она не может работать, т.к. написано - что доступ из папки.
Это файловый вариант работы 1с-ки.

Народ подскажите, есть такая проблемма, в воинской части стоит 1с(лицензия), с рашренной папки на сервере получают доступ к базе 2 бухглатера, но сейчас они расширяются и еще 2 бухгалтеров садят, все это дело скисает моментально, тоесть 3 еще работаю, но как только кто-либо начинает формировать отчет, все пипец, какие есть выходы, чтоб 1с работала быстрее?
если у тебя версия 1С 8.0-8.1 - легко перевести на клиент-серверный вариант, тогда проблемы исчезнут.

если же 7.7, то всё сложнее. Может быть 3 узких места:
1. Проведи профилактику 1с-ной базы (переиндексация, тестирование и исправление).
2. Смотри пропускную работу сети.
3. скорость жёского диска, на котором находится 1-ная бд.
Jura_22 07.11.2007, 16:59
если у тебя версия 1С 8.0-8.1 - легко перевести на клиент-серверный вариант, тогда проблемы исчезнут.

если же 7.7, то всё сложнее. Может быть 3 узких места:
1. Проведи профилактику 1с-ной базы (переиндексация, тестирование и исправление).
2. Смотри пропускную работу сети.
3. скорость жёского диска, на котором находится 1-ная бд.

Вот, сразу понятно граммотный человек, все понятно объяснил. Спасибо тебе.
Версия 7.7 базу проиндексировал, тестировать и исправлять нестал, у них три года несведено, да и остатки кривые, вообщем ЖОПА, сетка робит канал толстый, а вот жесткий диск да, это тоже ЖОПА РАТА 5400 оборотов. Спасибо за совет, если есть еще мысли пишите. Буду рад советам.
shiling 10.11.2007, 08:12
Вот, сразу понятно граммотный человек, все понятно объяснил. Спасибо тебе.
Версия 7.7 базу проиндексировал, тестировать и исправлять нестал, у них три года несведено, да и остатки кривые, вообщем ЖОПА, сетка робит канал толстый, а вот жесткий диск да, это тоже ЖОПА РАТА 5400 оборотов. Спасибо за совет, если есть еще мысли пишите. Буду рад советам.
Вы не написали какая ОС стоит на сервере. Но предполагаю что W2k/2003.
Основной причиной тормозов по данной осью является отрубание кэширования при подключении второго юзера к базе. И побороть это невозможно.
Выход тут один - юзеров в терминал садить.
Частично (процентов на 50-70 увеличить быстродействие) решить проблему возможно путем установки нормальной дисковой системы : нормальный SCSI рейд-контроллер + 4 диска в рейд10.
Так же стоит обратить внимание на подобность компов. то есть если у вас все компы минимум пень 4, а одна банка какой-нибудь древний целерончик, то он будет понижать быстродействие системы путем более догой блокировки таблиц на запись.
Ну и тормоза могут быть из-за бардака в базе : незакрытые регистры по измерениям ведут к разростанию таблиц регистров и как следствие - тормоза при отчетах.
Страница 2 из 7 1  2  3  4  5  6 / Последняя »
Похожие темы
Театр - предприятие убыточное. Ваше мнение?
Программирование на C/C++
Программирование на C#
Программирование на D
Программирование под .NET